HyperDex 1.6.0: MongoDB Compatibility

HyperDex Logo

We are proud to announce HyperDex 1.6, the next generation NoSQL data store that provides ACID transactions, schema-less documents, per-object authorization fault-tolerance, and high-performance. Some key features of HyperDex are:

This release brings the following changes and improvements:

  • MongoDB Compatibility: A new API, the Mongo Veneer, provides API compatibility with MongoDB. This API makes it possible to seamlessly switch from MongoDB to HyperDex

    Read more and see the mongo Veneer in action at in our companion post on MongoDB compatibility

  • Timestamp Type: A new data type makes storing timestamp data even easier.

HyperDex runs on 64-bit Linux (Ubuntu, Debian, Fedora, Centos) and OS X. Binary packages for Debian 7, Ubuntu 12.04,14.04, Fedora 20, and CentOS 6,7 are available [1], as well as source tarballs for other Linux platforms.

This release provides bindings for C, C++, Python, Node.js, Java, Ruby, and Go.

An evaluation version of Warp, and Warp bindings for Python, Java, and Ruby are available in the HyperDex repository. Install the "hyperdex-warp" package in your package manager to switch from HyperDex to Warp and test out the evaluation version.

Happy Hacking, The HyperDex Team

[1] http://hyperdex.org/download

Share on Google+
Share on Linkedin
Share on Reddit
Share on Tumblr
comments powered by Disqus